Zavarhatják a WLAN-hálózatokat a Google eszközei

Zavarhatják a WLAN-hálózatokat a Google eszközei

2018. január 18. 08:47, Csütörtök
A társaság bizonyos termékei több adattal terhelik le a vezeték nélküli hálózatokat, mint amennyit a routerek fel tudnak dolgozni.

A Google Cast nevű stream-technikában lévő hiba világszerte komoly fejfájást okoz a WLAN-t használóknak. A Myce nevű techblog arról írt, hogy a probléma különösen akkor lép fel, ha egy eszközön az Android 8.0 vagy 8.1 fut és az adott készülék ugyanabban a hálózatban aktív, amelyben egy vagy több Google Cast-kompatibilis termék is működik.

Az androidos okostelefonok általában 20 másodpercenként küldenek néhány kisebb adatcsomagot a WLAN-hálózatokon keresztül, hogy felfedezzék az elérhető Google Cast eszközöket és kapcsolatot építsenek fel azokhoz. Az aktuális Android-változatoknál viszont a normális esetben a kis adatcsomagok nem kerülnek továbbításra, hanem felhalmozódnak. Amennyiben viszont ilyen készülék "felébred", akkor rövid idő alatt 100 000 vagy még több úgynevezett MDNS multicast discovery packets csomagot küld el. A TP-Link nevű routergyártó egyik mérnöke közölte, hogy a szám annál magasabb, minél hosszabb ideig volt az eszköz nyugalmi állapotban.

A hirtelen nagy mennyiségű adatcsomag-továbbítás túlterheli a routereket, így azok vagy lekapcsolják az internethozzáférést vagy megszakítják az adott WLAN-hálózathoz csatlakozó készülékekkel a kapcsolatot. A legtöbb esetben elég lenne egy kis időt várni, amíg a router már nincs túlterhelve, de gyakran csak a router újraindítása segít.

A Google egyik szóvivője hangsúlyozta, hogy már dolgoznak a megoldáson. Addig két dolog közül választhatnak a felhasználók. Az egyik, hogy néhány gyártó - köztük a TP-Link és a Netgear - elérhetővé tett egyes termékeihez frissítéseket, így a routereket már nem bénítják meg az adatcsomagok. A másik lehetőség, hogy azt az eszközt, amely problémát okoz, eltávolítják a WLAN-hálózatból. Az adott okostelefont vagy táblagépet így csak abban a mobilhálózatban lehetne használni, amelyben elérhetővé teszik a szükséges frissítéseket.

Kapcsolódó linkek

Listázás a fórumban